Service outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 15:11 CST
Identified
The team has identified a problem affecting clients' access to the M1 platform and is currently implementing a fix. We apologize for the inconvenience.
Posted Dec 01, 2021 - 14:57 CST
This incident affected: Dashboard.