Dashboard latency and performance degradation
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted May 18, 2020 - 09:31 CDT
Investigating
We have identified an issue causing latency and degraded performance when accessing our dashboard. We are working to correct the issue and expect to have service restored shortly.
Posted May 18, 2020 - 09:27 CDT
This incident affected: Dashboard.