Scheduled maintenance
Incident Report for M1 Finance
Resolved
Scheduled maintenance is complete.
Posted Dec 16, 2021 - 18:56 CST
Monitoring
As part of our continued investment in building smarter tools for financial well-being, web and mobile applications will be down for scheduled maintenance this Thursday at 6 PM CT.
Posted Dec 16, 2021 - 18:10 CST