Upstream vendor outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Jun 11, 2021 - 13:00 CDT
Update
Our upstream vendor has identified the issue and is implementing a fix. Service should be mostly restored to customers now but we will continue to monitor the situation.
Posted Jun 11, 2021 - 11:43 CDT
Monitoring
Due to a problem with an upstream vendor, M1 Finance is currently inaccessible for customers in Chicago and LA. We apologize for the inconvenience and are working with them to provide prompt resolution.

More information can be found at https://www.cloudflarestatus.com/.
Posted Jun 11, 2021 - 11:27 CDT
This incident affected: Dashboard.