1D performance temporarily incorrect
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 09:57 CDT
Monitoring
Due to a delay in the delivery of market value data from a third party vendor, 1D performance calculations will be temporarily incorrect this morning for an hour or so. This is a visual issue that has no implications on trading. We are monitoring the situation and will post an update once a resolution has been reached.
Posted Sep 09, 2020 - 08:29 CDT
This incident affected: Performance.