Latency detected
Incident Report for M1 Finance
Resolved
M1 Finance would like to advise you that we have resolved the issue with the service response times and processing latency. All new activity and pending transactions are now being processed.
Posted Aug 01, 2018 - 11:56 CDT
Update
We are continuing to investigate this issue.
Posted Aug 01, 2018 - 11:30 CDT
Investigating
Problems with upstream vendors are causing latency in parts of our application.
Posted Aug 01, 2018 - 09:12 CDT
This incident affected: ACH Transfers and Account Signup.