Upstream documents vendor outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 01, 2018 - 14:56 CDT
Monitoring
Our upstream documents provider is experiencing problems. Users will temporarily be unable to retrieve documents (tax forms, statements, and confirms).
Posted 8 months ago. Oct 01, 2018 - 12:17 CDT
This incident affected: Statements & Confirms.