Brokerage statements and tax documents are temporarily unavailable
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted May 10, 2021 - 11:14 CDT
Update
We are continuing to investigate this issue.
Posted May 10, 2021 - 09:14 CDT
Investigating
Brokerage statements and tax documents are temporarily unavailable for some clients due to an upstream vendor problem. We apologize for the inconvenience and will provide updates on resolution as soon as they are available.
Posted May 10, 2021 - 09:14 CDT
This incident affected: Statements & Confirms.