Phone support temporarily down
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Dec 08, 2021 - 00:53 CST
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2021 - 10:26 CST
Monitoring
Due to a widespread AWS service outage, we are currently experiencing partial web and app outages. We are also unable to receive phone calls, so please reach out to us via email for client support. We appreciate your patience while this issue is resolved.

https://support.m1finance.com/hc/en-us/requests/new?ticket_form_id=360001449093
Posted Dec 07, 2021 - 09:59 CST
This incident affected: Dashboard and Market Data.