DNS Errors
Incident Report for M1 Finance
Resolved
The offending network issues have been resolved.
Posted Jun 24, 2019 - 07:45 CDT
Monitoring
We are being affected by the same route leak issue that is currently impacting CloudFlare and AWS: https://www.cloudflarestatus.com/incidents/46z55mdhg0t5

Some users will be able to connect properly but others, unfortunately, will not. We are still working with our upstream providers to correct this issue.
Posted Jun 24, 2019 - 07:37 CDT
Investigating
Our CDN is currently experiencing errors with loading client pages and our site is affected. We are working with them towards a resolution.
Posted Jun 24, 2019 - 06:18 CDT
This incident affected: Dashboard, Account Signup, and Statements & Confirms.