Upstream service disruption
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 18:25 CDT
Monitoring
We are experiencing an issue with an upstream service provider which may affect the availability of the Spend section of the platform on our web app. Impacted customers can access our mobile experiences as a temporary workaround. We apologize for the inconvenience and will provide updates as they become available.
Posted Oct 15, 2021 - 17:38 CDT
This incident affected: Spend.