CloudFlare Outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted 18 days ago. Jul 02, 2019 - 09:12 CDT
Update
Routing issues have been resolved for M1 Finance, we will continue to monitor and provide update as appropriate.
Posted 18 days ago. Jul 02, 2019 - 09:12 CDT
Identified
Currently CloudFlare is experiencing a network outage that is affecting the M1 site as well. The site itself is up and all trading operations are continuing normally.

https://www.cloudflarestatus.com/
Posted 18 days ago. Jul 02, 2019 - 08:55 CDT
This incident affected: Dashboard, Account Signup, and Statements & Confirms.