1D performance temporarily unavailable
Incident Report for M1 Finance
Resolved
The 1D performance issue has been resolved. Thank you for your patience.
Posted May 07, 2021 - 13:48 CDT
Investigating
1D performance is temporarily unavailable for a subset of clients due to an upstream data delivery problem. We apologize for the inconvenience and will provide updates on resolution as soon as they are available.
Posted May 07, 2021 - 11:30 CDT
This incident affected: Performance.