ACH provider outage
Incident Report for M1 Finance
Resolved
Service has been restored to our upstream ACH provider. ACH transfers are now completed and trading for affected accounts has begun. ETA for trades to be available within the dashboard is 11:30 AM CDT.
Posted Oct 09, 2018 - 10:58 CDT
Identified
Our upstream ACH provider is experiencing problems. Any deposits or withdrawals created today, scheduled or otherwise, will be delayed until resolution.

Trade windows of affected accounts are expected to be delayed as well until ACH resolution. We do not have an ETA at this time but will continue to provide regular updates until resolved.
Posted Oct 09, 2018 - 09:21 CDT
This incident affected: ACH Transfers and Trading.