Issues affecting our Web Portal
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Oct 19, 2021 - 21:18 CDT
Investigating
We are currently having issues in one of our systems that powers our web application. We are working on identifying and remediating the issue.
Posted Oct 19, 2021 - 21:08 CDT
This incident affected: Dashboard.