Networking issues detected
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted 5 months ago. May 28, 2019 - 08:26 CDT
Identified
We are experiencing degraded networking performance. Customers will notice intermittent latency during this time.
Posted 5 months ago. May 28, 2019 - 08:22 CDT
This incident affected: Dashboard and Borrow.