Direct deposit partial outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 10:19 CDT
Investigating
There is a known issue with received ACH deposits that seems to be widespread throughout the banking industry this morning. This can effect all direct deposits into your M1 Spend accounts. We are actively working with our banking partner Lincoln Savings Bank to get an update on the receival of all direct deposits.
Posted Sep 18, 2020 - 08:50 CDT
This incident affected: ACH Transfers.