Market Data Outage
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 09:24 CST
Identified
Please be aware that our upstream market data vendor is currently experiencing outages. We are working with them on a prompt resolution and will provide any updates as they become available to us.

Apologies for any inconvenience this may cause.
Posted Nov 05, 2019 - 09:16 CST
This incident affected: Market Data.