Dashboard performance calculations
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 10:54 CDT
Investigating
Due to delayed batch processing, performance calculations will be temporarily incorrect for a small subset of our customers. We apologize for the inconvenience.
Posted Oct 29, 2019 - 07:51 CDT
This incident affected: Market Data.