Phone support temporarily unavailable
Incident Report for M1 Finance
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 14:25 CDT
Monitoring
Due to an issue with our phone provider, our system is currently unable to take phone calls. We are hoping for a quick resolution. If you need to reach our team, please email us at https://support.m1finance.com/hc/en-us/requests/new?ticket_form_id=360001449093.
Posted Jun 04, 2021 - 13:43 CDT